P
Htek

Htek UC912E

Standard Business IP Phone, Wifi / Bluetooth, 4 Line Display, Gigabit Ethernet

MPNUC912EPower suppliesUpdated

Key facts

Part number
UC912E
Brand
Htek
Category
Power supplies
Price
AUD 149≈ USD 104 RRP
Availability
On request — ask for a quote

The Htek UC912E is a power supply listed in the Prology Parts Index. RRP AUD 149≈ USD 104 (Oct 2026). Request a quote for volume pricing, or sell us your used power supplies.

Overview

Phone Features

Up to 4 SIP accounts

Call hold, mute, DND

One-touch speed dial, hotline

Call forward, call waiting, call transfer

Redial, call return, auto answer, direct IP call

5-way conference

Group listening, SMS, emergency call

Ring tone selection/provisioning

Set date time automatically or manually

Dial plan per account

RTCP-XR (RFC3611), VQ-RTCPXR (RFC6035)

Action URL/URI

Voice Codecs Features

HD voice, HD handset, HD speaker

Codecs: iLBC, G.722, G.711(A/μ), Opus

GSM_FR, G.723, G.729AB, G.726-32

DTMF: In-band, RFC 2833, SIP INFO

Full-duplex hands-free speakerphone with AEC

VAD, AGC, CNG, AEC, PLC, AJB

Directory

Local phonebook up to 1000 entries

XML/LDAP remote phonebook

Intelligent search method

Phonebook search/import/export

Call history: dialed/received/missed/forwarded

Black list

IP-PBX Features

Busy Lamp Field (BLF), bridged Line Appearance(BLA)

Anonymous call, anonymous call rejection

Message Waiting Indicator (MWI) , voice mail

Call park, call pickup

Intercom, paging

Music on hold

Hot-desking

Display and Indicator

192x64 pixel graphical LCD with backlight

LED for call and message waiting indication

Illuminated LEDs for line status information

Intuitive user interface with icons and soft keys

National language selection

Caller ID with name, number

Feature keys

4 line keys with LED

4 line keys can be programmed up to

12 various features (4-page view)

Speaker key/headset key/mute key

4 context-sensitive “soft' keys

6 navigation keys, volume control keys

Speaker key/headset key/mute key 6 features keys: voice mail, headset, mute,speaker, transfer, redial

Interface

Dual-port Gigabit Ethernet

Power over Ethernet (IEEE 802.3af), class 2

1xRJ9 (4P4C) handset port

1xRJ9 (4P4C) headset port

Physical Features

Stand with 2 adjustable angles

Wall mountable

External universal AC adapter : AC 100~240V input and DC 5V/1.2A output

Power consumption (PSU): 1.8~4.4W

Power consumption (PoE):

Price history

Latest
AUD 149≈ USD 104
Oct 2026
Lowest recorded
AUD 149≈ USD 104
Highest recorded
AUD 149≈ USD 104
Recorded
2026
1 price point

AUD 149 rrp, recorded

Why buy from Prology

  • Tested before dispatchEvery item is checked by our technicians before it ships.
  • Warranty includedParts are covered by a Prology warranty – ask us for the terms.
  • Fast shippingDispatched from our Australian and US locations.
  • Real people, quick repliesQuotes and answers within 1 business day.

Request a quote for UC912E

Tell us the quantity and condition you need. Prology replies with a firm price and lead time within 1 business day.

Replies within 1 business day. Your details are used only to answer this request — privacy.

More Htek Power supplies

All Htek parts starting with “U” · All Htek part numbers

We buy it

Have this part spare? We buy it

Prology buys used and surplus power supplies – including UC912E. Sell outright or trade in against your next order. Offer within 1 business day.